Jenifer (Zarknorph)

The Midnight Castle Forum On Delphi

Hosted by Jenifer (Zarknorph)|All FAQs Answered Here!

A forum devoted to the FTP game Midnight Castle. All formats and platforms. Find Friends, learn tips and tricks, read strategy guides, ask for help or just kick back in Fletcher's Tea Room and dodge the odd explosion.

  • 2809
    MEMBERS
  • 133347
    MESSAGES
  • 41
    POSTS TODAY

Discussions

Frozen game, please help   Technical Issues

Started Jan-16 by Howdah (smitcheltree); 284 views.

Looking for suggestions. I logged into game about 7:30 this morning, 1:30 GMT. I gifted 5 friends, spun wheel and played dice. I started to make my way through the rooms to play the ones that had changed since last night. I got about 1/3 of the way through and PC froze. Soft booting didn't work (Ctrl, Alt, Delete) so I hard booted. Tried to go back into game and it froze agani, had to hard boot it again. I have restarted PC several times and it freezes each time. Sometimes just black screen, sometimes Elephant screen and once it got as far as Anabelle before it froze. I have tried waiting for several minutes to see if it would resolve on it's own, but it does not. I tried opening BF game launcher to uninstall and reinstall game but could not get past opening sceen at BF. Next play was to try to contact support, but being Saturday don't expect them to be available, and don't know how to get to support except through the game or through BF. It is now almost 4:00 pm, Midnight GMT and I have not been able to do last round of gifting, etc. 

Is there any thing anyone can suggest on how to fix this or how to get in touch with tech support? 

 

Thank you everyone

 

mdpetdoc

From: mdpetdoc

Jan-16

See if you have a recent windows update. I got one yesterday that I had to revert because it was freezing a different BF game. It's working fine now. I've paused updates to give Windows time to fix whatever the issue might be. 

I did have an update a few days ago but I have been playing MC every day since. I do have a problem with freezing from time to time, and lagging often, but it until today a reboot has always solved the problem. 

TOP