Delphi Forums Member Services

Hosted by DelphiForums|www.delphiforums.com/support

The Delphi Member Services Forum is for all your membership issues including using Delphi, billing questions, bug reports, and suggestions.

  • 244563
    MEMBERS
  • 248140
    MESSAGES
  • 6
    POSTS TODAY

Discussions

I am really hacked off!   Billing - Plus/Extra

Started 12/8/17 by JZBelle; 1790 views.
JZBelle

From: JZBelle

12/8/17

No wonder you are confused -- I should have said Delphi Extra for one year and not plus. Sorry about that.  I tried to edit my post and found not a way to do that.

I know this is getting straightened out for you now but wanted to show you where Edit is. Just click on the triangle next to Reply

 

JZBelle

From: JZBelle

12/8/17

Awww thank you - I see it now.  Maybe I can find my other post and fix it (LOL).  TY for your help Kid.

Ha ha - :) 

No worries Julea. That was a nice thing to do for your contest winners. 

JZBelle

From: JZBelle

12/8/17

I've done it several times over the years and I love doing it.  Just was disappointed when I didn't see Extra anymore.  Walt is working on it -- or at least he told me who to write to.  I have.  I hope something happens where the ladies can get a full year in.

JZBelle

From: JZBelle

12/10/17

Hi Walt.  Well, this thing with the "Extra" subscription is not over yet.

I did as you told me to -- wrote the service end and did not hear one peep back.

The ladies are showing that they do have the PLUS subscription.  That is NOT what I wanted them to have.  The PLUS for them expires on March 18.  I wanted them to have the EXTRA which gives then 1 full year!  Please, what can be done about this?  To me, Delphi needs to make this good.  Giving them plus doesn't do it!  They really don't even need plus because they don't have their own forums!

Julea

JZBelle

From: JZBelle

12/10/17

I'm willing to bet that Delphi has lost many customers because of this mess.  You advertise that you have Extra, but don't, evidently!

WaltHowe
Staff

From: WaltHowe

12/10/17

I have been looking for your message to service@delphiforums.com, and I have not seen it. Are you sure you addressed it correctly? 

Another way to handle it is to respond to my message here by email, using the Options menu.

JZBelle

From: JZBelle

12/10/17

I'll send it to you now.

Just released it to "You" at 2 different emails -- seems I have 2 for you.   If you do not get either of those, please let me know and I'll use the email option here.  Thanks.

Julea

  • Edited December 10, 2017 1:47 pm  by  JZBelle
WaltHowe
Staff

From: WaltHowe

12/10/17

It is all fixed now. I replied to you by email with the details.

TOP