_V Star 1100 Riders_

Hosted by Sick Mick* (quick_mick)|The V Star 1100 Wiki Knowledge Base

The Very Best Information Source for All Models of the V Star XVS 1100

  • 31560
    MEMBERS
  • 812727
    MESSAGES
  • 0
    POSTS TODAY

Discussions

AIS Plugs   General Discussion

Started Oct-29 by 2k1VStarRide; 1082 views.
2k1VStarRide

From: 2k1VStarRide

Oct-30

Another good option to keep in mind.

Riding season is mostly finished up here.

Will start working on the bike soon.

Thanks for your input.

Donn (99Orton)

From: Donn (99Orton)

Nov-1

I've heard the same about Barons plugs cracking the heads. Probably installer error but it's what I've read.

gradie55

From: gradie55

Nov-1

probably because they didn't read the instructions.. to tighten lightly...  mine are still in .. had all sorts of head work down .. and lots of pressure in them cylinders.. it concerns me ... but hasn't broke yet.. 

Donn (99Orton)

From: Donn (99Orton)

Nov-2

I believe the heads were being broken during the install of the plugs for some reason.

Some people can screw up anything. :)

crazeeharry

From: crazeeharry

Nov-4

Yes, you're right Tim,

and they're called "the Government!

crazeeharry

From: crazeeharry

Nov-4

Ron,

I heard people beat the barons plugs in way too hard, or they freeze them first and pound them in real hard....

If a .45ACP casing will hold, then a hammer is not needed.... Some people shouldn't be allowed to have hammers!  ( : ))

ABE (spud116)

From: ABE (spud116)

Jan-1

I replied to your PM from back in Sept, check it.

TOP