Extensions -  Extensions in Private Browsing (149 views) Notify me whenever anyone posts in this discussion.Subscribe
 
From: Kid (Kidmagnet) DelphiPlus Member Icon Posted by hostJun-8 11:43 AM 
To: All  (1 of 8) 
 7442.1 

Starting with V67 Firefox has made a change in the way Extensions work with Private Browsing, you must now "Allow" them to run.

 

https://support.mozilla.org/en-US/kb/extensions-private-browsing?as=u&utm_source=inproduct

Older extensions will have permissions enabled so check yours to see which ones you want running in your Private windows and which you do not.

 

 

Once you click on an extension you will have access to the permissions for it. Simply click on the Allow (or Don't Allow) buttons to make the change, no Save needed.

  • Edited June 11, 2019 12:44 pm  by  Kid (Kidmagnet)
 

 
From: Kid (Kidmagnet) DelphiPlus Member Icon Posted by hostJun-8 11:45 AM 
To: Tank (tgeery) DelphiPlus Member Icon  (2 of 8) 
 7442.2 in reply to 7442.1 

I wonder if the development of that feature was what messed up all extensions previously? OR was this already discovered and discussed here and flew over my head lol

 

 
From: Tank (tgeery) DelphiPlus Member Icon Posted by hostJun-9 8:50 PM 
To: Kid (Kidmagnet) DelphiPlus Member Icon  (3 of 8) 
 7442.3 in reply to 7442.2 

I personally believe that the temporary disabling of ALL extensions could have happened while Mozilla was developing the new feature - yes.  I haven't seen any discussion on it but I don't frequent any sites  where that discussion would take place either.

Sorry for the delayed response - I was out of town for four days...
 

 

 
From: Kid (Kidmagnet) DelphiPlus Member Icon Posted by hostJun-11 12:34 PM 
To: Tank (tgeery) DelphiPlus Member Icon  (4 of 8) 
 7442.4 in reply to 7442.3 

No worries!

 

 
From: Kid (Kidmagnet) DelphiPlus Member Icon Posted by hostJun-11 12:46 PM 
To: All  (5 of 8) 
 7442.5 in reply to 7442.4 

I edited post #1 to include screenshots and clearer information. As I am promoting this thread and not everyone is a Firefoxy as you regulars (wink) please feel free to add to this thread with relevant info or to correct anything I've gotten wrong.

Thanks!
 

 

 
From: Kid (Kidmagnet) DelphiPlus Member Icon Posted by hostJun-11 12:52 PM 
To: All  (6 of 8) 
 7442.6 in reply to 7442.5 

When I updated to V67 on my Windows 10 this notification either did not appear or I never read it. Like others I have these pop up so often I barely read them when multitasking.

 

When I updated my Windows 7 computer I noticed it.

 

 
From: Tank (tgeery) DelphiPlus Member Icon Posted by hostJun-11 1:13 PM 
To: Kid (Kidmagnet) DelphiPlus Member Icon  (7 of 8) 
 7442.7 in reply to 7442.6 

I saw the notice as well on each of the computers that I use.
 

 

 
From: Kid (Kidmagnet) DelphiPlus Member Icon Posted by hostJun-11 2:00 PM 
To: Tank (tgeery) DelphiPlus Member Icon  (8 of 8) 
 7442.8 in reply to 7442.7 

I must have missed it on win 10 but this machine has not always done things as expected since it's force OS upgrade ;)

 

First Discussion>>

 
Adjust text size:

Welcome, guest! Get more out of Delphi Forums by logging in.

New to Delphi Forums? You can log in with your Facebook, Twitter, or Google account or use the New Member Login option and log in with any email address.

Home | Help | Forums | Chat | Blogs | Privacy Policy | Terms of Service
© Delphi Forums LLC All rights reserved.