Delphi Forums: Hosts Support

Hosted by DelphiForums|www.delphiforums.com/support

This is Delphi Forums' official support forum for Hosts. Ask questions, discuss problems, give feedback, and share tips about running a successful forum.

  • 59231
    MEMBERS
  • 232455
    MESSAGES
  • 0
    POSTS TODAY

Discussions

Change to embedded links   Technical Issues /Bugs

Started Mar-28 by Showtalk; 5135 views.
Showtalk
Staff

From: Showtalk

May-30

Testing

The original link 

https://www.wikihow.com/Exercise

The embed code

<div class="df-embeddable" data-url="https://www.wikihow.com/Exercise">
<div class="df-embedded df-link">
<div class="df-head"><a href="https://www.wikihow.com" target="_blank"><img border="0" class="df-favicon" data-color="#8DB070" height="16" src="https://www.wikihow.com/favicon.ico" width="16" />wikiHow</a></div>

<div class="df-body">
<div class="media"><a class="pull-left" href="https://www.wikihow.com/Exercise" target="_blank"><img class="media-object" src="https://www.wikihow.com/images/6/60/Exercise-Step-2-Version-2.jpg" /></a>

<div class="media-body">
<h4 class="media-heading"><a href="https://www.wikihow.com/Exercise" target="_blank">How to Exercise</a></h4>

<p class="df-desc">Exercise is a key part of staying healthy, but figuring out how to get more active can be tough. If you&#39;re not used to physical activity, start slow. Go for 10 to 15 minute walks, and work your way up to briskly walking or jogging for 30...</p>
<a href="https://www.wikihow.com/Exercise" target="_blank">Read more from wikiHow</a></div>

WALTER784

From: WALTER784

May-30

This is my exact copy and paste of your HTML:
WALTER784

From: WALTER784

May-30

Comparing your original to my posted copy of your original, it looks like Delphi editor has broken up and re-ordered several [<div class=] tags which seems to be the problem.

FWIW

Showtalk
Staff

From: Showtalk

May-30

How do we bypass the div tags?

  • Edited May 30, 2022 3:59 pm  by  Showtalk
WALTER784

From: WALTER784

May-31

The Delphi editor modifies them, so you'll have to remove them or replace them with other tags that the editor won't modify.

Edited to add: Or get Delphi to modify their editor and allow those tags "as is"... unmodified!

FWIW

  • Edited May 31, 2022 1:12 am  by  WALTER784
Showtalk
Staff

From: Showtalk

May-31

We have to live with the editor we have now.

WALTER784

From: WALTER784

Jun-1

Then you will have to remove the offending tags.

FWIW

Well that's fine if you have access to source.

However this is a bug for tech to work on, not the user.

Still jumps to the top for me on iOS safari iPhone too.

Try this... tap on the icon and paste in the link, tap OK.

You might see this, just a blue line.
 

Without tapping in the compose area, tap on your embed icon again... it will still show the link, just tap OK again.

It works for me. And does so on any forum (Zeta or Classic) with desktop and other browsers.


 

CC to gunter

When you pass this on to tech can you tell them I've had this problem in only some forums for ages... no one else reported it (I may have via Cstar... so quite a bit ago) and I had a work around so it dlipped my mind.

It's currently and suddenly happening to users at the midnightcastle forum (the article embeds not publishing) and the work around works for me there. 

TOP