Jenifer (Zarknorph)

The Midnight Castle Forum On Delphi

Hosted by Jenifer (Zarknorph)|All FAQs Answered Here!

A forum devoted to the FTP game Midnight Castle. All formats and platforms. Find Friends, learn tips and tricks, read strategy guides, ask for help or just kick back in Fletcher's Tea Room and dodge the odd explosion.

  • 3816
  • 161918
  • 17


No Update on PC-Try This to Fix   Technical Issues

Started May-6 by Tammy27 (DoubleMsMom); 1852 views.

So this seems to come up almost every update, so decided to create a discussion of what works for most players on PC.

First a caveat:

DO NOT UNINSTALL/REINSTALL ON iPAD!!!!! OR KINDLE/ANDROID DEVICES........................You will lose your game!!!! on the device.

So for PC players;

First check your Game Manager. If you don't see an update, then you may have to check manually. Click on Options (upper right corner of Game Manager), then click the Downloads tab, under Game Updates click manually then OK. If nothing appears then you are going to have to uninstall and reinstall the game.

To do this click on My Games (the left side of the Game Manager), then click on the trash can icon to uninstall the game.  Then click on PC Games (the left side of the Game Manager), in the search box type in Midnight Castle. When it appears, click to download. Then relaunch the game and the game should automatically update.

If this doesn't work, then you'll have to contact either Big Fish or Elephant Games. You'll find their contact info here:

Links for Game Support (

Once again, this possible fix only works for players on PCDO NOT UNINSTALL/REINSTALL ON iPAD!!!!! OR KINDLE/ANDROID DEVICES........................You will lose your game!!!! on the device.

Update:  8/16/23--During the20th EG Anniversary Event update another issue arose, Error Code 6

Here is a solution from LvlSlgr:


From: LvlSlgr

1:05 PM

This is based on one of the suggestions they gave for Error 6 -

In the Game Manager, click on the *Options tab at the top. When the Options window opens, click on the Advanced tab. This will open a window for Netword Connection. It should normally be set at Default (recommended). Mine wasn't - I have no idea when or how it got changed. But when I set it back to Default then I was able to get the download to complete. Good luck!

Di (amina046)

From: Di (amina046)


Thank you very much for your encouragement! I did it for the 1st time and with success. heart_eyes

Happy to hear this worked for you!!

Keep stormin' the castle!!


From: LvlSlgr


The solution that Tammy added to the first post here was when I had a slightly different problem. The update was showing in the Game Manager but each time I tried to download it, I got an error. See below from where I first posted that I was having a problem. The "Uninstall/Reinstall" that was suggested didn't work and I had to do something else. That is what Tammy included in her first post.

From: LvlSlgr


I keep getting an error when trying to download the update. 

If you get this on your PC, it tells you to uninstall your game and download it again. Something I've done in the past successfully.


From: Magiemagaluf


Thank you so much for this info.  With great dread, great intrepidation and all fingers crossed, I followed your instructions and got my game back, with the new download and all my bits and pieces in tack>

Thank you again

You're welcome, happy to hear you're back stormin' the castle!!


From: PlayerTerry


Thank you, Tammy, from me as well.